Inicio / Content / Si usas Drupal para tu web, ¡actualiza!

Si usas Drupal para tu web, ¡actualiza!

Si usas Drupal para tu web, ¡actualiza!

Fecha de publicación: 
21/04/2022
Importancia: 
3 - Media
Recursos afectados: 

Las versiones de Drupal anteriores a:

  • Drupal 9.3.12,
  • Drupal 9.2.18
Descripción: 

Se han detectado dos vulnerabilidades de severidad media en core de Drupal, que afectan a la API (Applications Programming Interface) de formularios (Form API) y a la API de entidades (Entity API).

Solución: 

Se recomienda actualizar Drupal a la última versión disponible. Para ello, puedes acceder a los siguientes enlaces:

Todas las versiones de Drupal 9, anteriores a 9.2.x, están al final de su ciclo de vida y no reciben actualizaciones de seguridad. Drupal 8 ha llegado al final de su vida útil. Drupal 7 no está afectado por las vulnerabilidades.

Es importante proteger el gestor de contenidos para evitar que sea vulnerable. Sigue este checklist para evitar posibles ataques de ciberdelincuentes, algunos de ellos explicados en casos reales:

¿Te gustaría estar a la última con la información de nuestros avisos? Anímate y suscríbete a nuestros boletines, al canal de Telegram @ProtegeTuEmpresa, al perfil de twitter @ProtegeEmpresa o síguenos en Facebook. Serás el primero en enterarte de los últimos avisos de seguridad para empresas. También ponemos a tu disposición la Línea gratuita de Ayuda en Ciberseguridad de INCIBE, 017; y nuestros canales de chat de WhatsApp (900 116 117) y Telegram (@INCIBE017), o mediante el formulario web.

Detalle: 

Drupal con logo PtE

Los detalles de las vulnerabilidades son los siguientes:

  • La API de formularios del núcleo de Drupal tiene una vulnerabilidad en la que algunos formularios de módulos personalizados pueden ser vulnerables a una validación de entrada inadecuada. Esto podría permitir a un ciberatacante inyectar valores no permitidos o sobrescribir datos. Aunque los formularios afectados no son de uso común, podrían alterarse datos críticos o sensibles. No se han encontrado formularios afectados del core, aunque sí podrían estar afectados los formularios de proyectos personalizados. La actualización corregirá estos formularios.
  • Drupal 9.3 implementó una API de acceso a entidades genéricas (entidades de contenido y de configuración) para poder revisarlas. No obstante, esta API no se integró del todo con los permisos previamente existentes, lo que ha dado lugar a una posible evasión de acceso para usuarios que tienen autorización para revisar contenido, pero no tienen acceso al módulo ‘node’ (de publicación y gestión de contenidos) ni al de ‘media’ (para la gestión de diferentes tipos de ficheros digitales: imágenes, archivos, etc.). Esta vulnerabilidad solo afecta a sitios que utilicen el sistema de revisiones de Drupal.

Tu soporte técnico puede consultar una solución más detallada en el área de avisos de INCIBE-CERT.

Línea de ayuda en ciberseguridad 017