Home / Node / Corregidas varias vulnerabilidades en Moodle

Corregidas varias vulnerabilidades en Moodle

Corregidas varias vulnerabilidades en Moodle

Publication date: 
07/21/2020
Importance: 
4 - Alta
Affected resources: 

Versiones deMooodle:

  • 3.9;
  • 3.8 a 3.8.3;
  • 3.7 a 3.7.6:
  • 3.5 a 3.5.12;
  • y todas las versiones anteriores sin soporte.
Description: 

La plataforma de formación Moodle ha publicado una actualización de seguridad que soluciona 4 vulnerabilidades, 3 de ellas de severidad alta y 1 de severidad baja.

Solution: 

Se recomienda actualizar Moodle a la última versión disponible, para ello puedes acceder al siguiente enlace:

Si utilizas otra versión de Moodle que continúa con soporte, puedes acceder a los enlaces de descarga que corrigen la vulnerabilidad.

Es importante proteger el gestor de contenidos para evitar que sea vulnerable. Sigue este checklist para evitar posibles ataques de ciberdelincuentes, algunos de ellos explicados en casos reales:

¿Te gustaría estar a la última con la información de nuestros avisos? Anímate y suscríbete a nuestros boletines, al canal de Telegram @ProtegeTuEmpresa, al perfil de twitter @ProtegeEmpresa o síguenos en Facebook. Serás el primero en enterarte de los últimos avisos de seguridad para empresas. También ponemos a tu disposición una línea gratuita de ayuda en ciberseguridad de INCIBE: 017.

Detail: 

Moodle actualización

La actualización de seguridad corrige, por un lado, una vulnerabilidad que permitiría a un ciberdelincuente realizar un ataque de Denegación de Servicio o DoS contra la web, saturándola de peticiones gracias a un fallo en el número de archivos que se pueden cargar.

La segunda de las vulnerabilidades corregidas, de severidad alta, habilitaría la posibilidad de realizar una escalada de privilegios, es decir, permitiría acceder al rol de manager a un usuario identificado como maestro.

La tercera de las vulnerabilidades, de severidad alta, se corrige mediante el establecimiento de un filtro adicional en el registro de tareas del sistema, lo que evita la realización de un ataque de tipo Cross Site Scripting (XSS) reflejado.

Por último, en la vulnerabilidad más leve se corrigen los fallos presentes en una librería usada por jQuery que podría ser utilizada con fines ilegítimos.

Tu soporte técnico puede consultar una solución más detallada en el área de avisos del INCIBE-CERT.

Línea de ayuda en ciberseguridad 017