CVE

CVE-2023-49735

Severity:
HIGH
Type:
CWE-22 Path Traversal
Publication date:
30/11/2023
Last modified:
12/12/2023

Description

** UNSUPPORTED WHEN ASSIGNED **<br /> <br /> The value set as the DefaultLocaleResolver.LOCALE_KEY attribute on the session was not validated while resolving XML definition files, leading to possible path traversal and eventually SSRF/XXE when passing user-controlled data to this key. Passing user-controlled data to this key may be relatively common, as it was also used like that to set the language in the &amp;#39;tiles-test&amp;#39; application shipped with Tiles.<br /> <br /> This issue affects Apache Tiles from version 2 onwards.<br /> <br /> NOTE: This vulnerability only affects products that are no longer supported by the maintainer.<br /> <br />

Vulnerable products and versions

CPE From Up to
cpe:2.3:a:apache:tiles:*:*:*:*:*:*:*:* 2.0 (including)


References to Advisories, Solutions, and Tools

botón arriba