CVE

CVE-2023-5909

Severity:
HIGH
Type:
CWE-295 Improper Certificate Validation
Publication date:
30/11/2023
Last modified:
06/12/2023

Description

<br /> <br /> <br /> <br /> <br /> <br /> <br /> <br /> <br /> KEPServerEX does not properly validate certificates from clients which may allow unauthenticated users to connect.<br /> <br /> <br /> <br /> <br /> <br /> <br /> <br />

Vulnerable products and versions

CPE From Up to
cpe:2.3:a:ge:industrial_gateway_server:*:*:*:*:*:*:*:* 7.614 (including)
cpe:2.3:a:ptc:keepserverex:*:*:*:*:*:*:*:* 6.14.263.0 (including)
cpe:2.3:a:ptc:opc-aggregator:*:*:*:*:*:*:*:* 6.14 (including)
cpe:2.3:a:ptc:thingworx_industrial_connectivity:-:*:*:*:*:*:*:*
cpe:2.3:a:ptc:thingworx_kepware_edge:*:*:*:*:*:*:*:* 1.7 (including)
cpe:2.3:a:ptc:thingworx_kepware_server:*:*:*:*:*:*:*:* 6.14.263.0 (including)
cpe:2.3:a:rockwellautomation:kepserver_enterprise:*:*:*:*:*:*:*:* 6.14.263.0 (including)
cpe:2.3:a:softwaretoolbox:top_server:*:*:*:*:*:*:*:* 6.14.263.0 (including)


References to Advisories, Solutions, and Tools

botón arriba