CVE-2026-105134
Severity CVSS v4.0:
CRITICAL
Type:
CWE-77
Command Injection
Publication date:
04/10/2026
Last modified:
26/10/2026
Description
A flaw has been found in Ahsay AhsayCBS up to 9.15.2.69/10.3.4.44. This vulnerability affects unknown code of the file /rps/api/json/UpdateReceivers.do of the component Replication Receiver. Executing a manipulation of the argument random can lead to os command injection. It is possible to launch the attack remotely. The exploit has been published and may be used. Upgrading to version 9.15.2.70 and 10.3.4.45 is able to resolve this issue. Upgrading the affected component is advised. The initial patch did not fix the security vulnerability properly. An update of the CVE entry to reflect this became necessary.
Impact
Base Score 4.0
10.00
Severity 4.0
CRITICAL
Base Score 3.x
10.00
Severity 3.x
CRITICAL
Base Score 2.0
10.00
Severity 2.0
HIGH
Vulnerable products and versions
| CPE | From | Up to |
|---|---|---|
| cpe:2.3:a:ahsay:cloud_backup_suite:*:*:*:*:*:*:*:* | 9.15.2.70 (excluding) | |
| cpe:2.3:a:ahsay:cloud_backup_suite:*:*:*:*:*:*:*:* | 10.1.0 (including) | 10.3.4.45 (excluding) |
To consult the complete list of CPE names with products and versions, see this page
References to Advisories, Solutions, and Tools
- https://vuldb.com/cve/CVE-2026-105134
- https://vuldb.com/submit/942743
- https://vuldb.com/vuln/413351
- https://vuldb.com/vuln/413351/cti
- https://www.ahsay.com/en/company/announcements/patch-cve-105133-105134-update
- https://www.huntress.com/blog/ahsaycbs-flaws-exploit
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-105134


