Omisión de autenticación en Cisco BroadWorks y servicios Xtended

Fecha de publicación
07/09/2023
Importancia
5 - Crítica
Recursos Afectados

La vulnerabilidad afecta a Cisco BroadWorks Application Delivery Platform y Cisco BroadWorks Xtended Services Platform si se ejecuta una versión vulnerable de Cisco BroadWorks y con una de las siguientes aplicaciones habilitadas:

  • Servicio de autenticación;
  • BWCallCenter;
  • BWRecepcionista;
  • Recuperación de archivos multimedia personalizados;
  • ModeradorClienteApp;
  • Consulta públicaECL;
  • Informes públicos;
  • UCAPI;
  • Acciones Xsi;
  • Xsi-Eventos;
  • Xsi-MMTel;
  • Xsi-VTR.
Descripción

Cisco ha publicado una vulnerabilidad de severidad crítica que podría permitir que un atacante remoto, no autenticado, falsifique las credenciales necesarias para acceder a un sistema afectado.

Solución

Cisco ha lanzado actualizaciones de software gratuitas que solucionan la vulnerabilidad descrita. 

Los clientes con contratos de servicio que les dan derecho a actualizaciones periódicas de software deben obtener correcciones de seguridad a través de sus canales de actualización habituales.

Detalle

La vulnerabilidad de severidad crítica se debe al método utilizado para validar los tokens de SSO. Un atacante podría aprovechar esta vulnerabilidad autenticándose en la aplicación con credenciales falsificadas. Una explotación exitosa podría permitir al atacante cometer un fraude telefónico o ejecutar comandos en el nivel de privilegio de la cuenta falsificada. Si esa cuenta es una cuenta de administrador, el atacante tendría la capacidad de ver información confidencial y modificar la configuración del cliente o de otros usuarios. Para aprovechar esta vulnerabilidad, el atacante necesitaría una identificación de usuario válida asociada con un sistema Cisco BroadWorks afectado.

Se ha asignado el identificador CVE-2023-20238 para esta vulnerabilidad.

botón arriba