CVE

Vulnerabilidad en el procesamiento del comando "ConnectMe" en la solución ZOOK (CVE-2020-7877)

Severidad:
ALTA
Type:
CWE-120 Copia de búfer sin comprobación del tamaño de entrada (Desbordamiento de búfer clásico)
Fecha de publicación:
07/09/2021
Última modificación:
16/09/2021

Descripción

Se ha detectado un problema de desbordamiento de búfer en la solución ZOOK (herramienta de administración remota) al procesar el comando "ConnectMe" mientras es analizado un valor OUTERIP diseñado debido a una falta de comprobación de límites. Esta vulnerabilidad permite al atacante ejecutar un comando arbitrario remoto

Productos y versiones vulnerables

CPE Desde Hasta
cpe:2.3:a:mastersoft:zook_agent:2.0.6.1:*:*:*:*:*:*:*
cpe:2.3:a:mastersoft:zook_viewer:2.0.4.6:*:*:*:*:*:*:*
cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:*


Referencias a soluciones, herramientas e información