Múltiples vulnerabilidades en productos de Schneider Electric

Fecha de publicación
13/06/2023
Importancia
4 - Alta
Recursos Afectados
  • Afectado únicamente por CVE-2023-3001:
    • IGSS Dashboard, versiones 16.0.0.23130 y anteriores.
  • Afectado por CVE-2023-2569 y CVE-2023-2570:
    • EcoStruxureTM Foxboro DCS Control Core Services, todas las versiones anteriores al parche HF9857795.
  • Afectados por CVE-2023-1049:
    • Pro-face BLUE, versiones 3.3 SP1 y anteriores;
    • EcoStruxure™ Operator Terminal Expert, versiones 3.3 SP1 y anteriores.
Descripción

Diversos investigadores han reportado a Schneider Electric 4 vulnerabilidades de severidad alta, cuya explotación podría permitir a un atacante ejecutar código no autorizado, provocar una pérdida de control del sistema SCADA, ejecutar una denegación de servicios o una escalada de privilegios.

Solución

Schneider Electric ha lanzado distintos parches para solucionar las vulnerabilidades descritas:

  • IGSS Dashboard: actualizar al a versión 16.0.0.23131;
  • EcoStruxureTM Foxboro DCS Control Core Services: aplicar el parche HF9857795;
  • Pro-face BLUE: actualizar a la versión 3.4;
  • EcoStruxure™ Operator Terminal Expert: actualizar a la versión 3.4.
Detalle

La vulnerabilidad en el módulo Dashboard podría causar una interpretación de datos maliciosos de carga útil, permitiendo, en última instancia, una ejecución remota de código, siempre y cuando el atacante consiga que el usuario abra un archivo malicioso. Se ha asignado el identificador CVE-2023-3001 para esta vulnerabilidad.

Existe dos vulnerabilidad que podrían causar una condición de denegación de servicio, así como una ejecución en el kernel cuando un atacante malicioso con acceso local cree un script utilizando una llama IOCTL en el controlador Foxboro.sys. Se han asignado los identificadores CVE-2023-2569 y CVE-2023-2570 para estas vulnerabilidades.

La vulnerabilidad de inyección de código podría permitir a un actor malicioso ejecutar código cuando un usuario cargue un archivo de proyecto desde el sistema de archivos local en el HMI. Se ha asignado el identificador CVE-2023-1049 para esta vulnerabilidad.

botón arriba