CVE

Vulnerabilidad en Sinatra (CVE-2022-45442)

Severidad:
ALTA
Type:
No Disponible / Otro tipo
Fecha de publicación:
28/11/2022
Última modificación:
01/02/2023

Descripción

*** Pendiente de traducción *** Sinatra is a domain-specific language for creating web applications in Ruby. An issue was discovered in Sinatra 2.0 before 2.2.3 and 3.0 before 3.0.4. An application is vulnerable to a reflected file download (RFD) attack that sets the Content-Disposition header of a response when the filename is derived from user-supplied input. Version 2.2.3 and 3.0.4 contain patches for this issue.

Productos y versiones vulnerables

CPE Desde Hasta
cpe:2.3:a:sinatrarb:sinatra:*:*:*:*:*:*:*:* 2.0.0 (incluyendo) 2.2.3 (excluyendo)
cpe:2.3:a:sinatrarb:sinatra:*:*:*:*:*:*:*:* 3.0.0 (incluyendo) 3.0.4 (excluyendo)
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*


botón arriba