CVE

Vulnerabilidad en Katran (CVE-2023-49062)

Severidad:
ALTA
Type:
No Disponible / Otro tipo
Fecha de publicación:
28/11/2023
Última modificación:
04/12/2023

Descripción

Katran podría revelar memoria del kernel no inicializada como parte de un encabezado IP. El problema estaba presente en la encapsulación IPv4 y en la generación de paquetes ICMP (v4) Too Big. Después de una llamada a bpf_xdp_adjust_head, el código Katran no inicializó el campo de identificación para el encabezado IPv4, lo que resultó en la escritura del contenido de la memoria del kernel en ese campo del encabezado IP. El problema afectó a todas las versiones de Katran antes del commit 6a03106ac1eab39d0303662963589ecb2374c97f

Productos y versiones vulnerables

CPE Desde Hasta
cpe:2.3:a:facebook:katran:*:*:*:*:*:*:*:* 2023-11-15 (excluyendo)


botón arriba