CVE

Vulnerabilidad en CarrierWave (CVE-2023-49090)

Severidad:
MEDIA
Type:
CWE-79 Neutralización incorrecta de la entrada durante la generación de la página web (Cross-site Scripting)
Fecha de publicación:
29/11/2023
Última modificación:
05/12/2023

Descripción

CarrierWave es una solución para carga de archivos para Rails, Sinatra y otros frameworks web Ruby. CarrierWave tiene una vulnerabilidad de omisión de lista permitida de tipo de contenido, que posiblemente conduzca a XSS. La validación en `allowlisted_content_type?` determina los permisos de tipo de contenido realizando una coincidencia parcial. Si al argumento `content_type` de `allowlisted_content_type?` se le pasa un valor creado por el atacante, se permitirán los tipos de contenido no incluidos en `content_type_allowlist`. Este problema se solucionó en las versiones 2.2.5 y 3.0.5.

Productos y versiones vulnerables

CPE Desde Hasta
cpe:2.3:a:carrierwave_project:carrierwave:*:*:*:*:*:ruby:*:* 2.2.5 (excluyendo)
cpe:2.3:a:carrierwave_project:carrierwave:*:*:*:*:*:ruby:*:* 3.0.0 (incluyendo) 3.0.5 (excluyendo)


botón arriba