[Actualización 03/03/2023] Múltiples vulnerabilidades en UPS CS141 de Generex

Fecha de publicación
24/02/2023
Importancia
5 - Crítica
Recursos Afectados
  • UPS CS141, versiones anteriores a 2.06
Descripción

INCIBE ha coordinado la publicación de 7 vulnerabilidades en el adaptador UPS CS141 de Generex, que han sido descubiertas por Joel Gámez Molina (@JoelGMSec).

A estas vulnerabilidades se les han asignado los códigos:

  • CVE-2022-47186. Puntuación base CVSS v3.1 de 7,5, siendo el cálculo del CVSS: AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N.
  • CVE-2022-47187. Puntuación base CVSS v3.1 de 5,3, siendo el cálculo del CVSS: AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N.
  • CVE-2022-47188. Puntuación base CVSS v3.1 de 7,5, siendo el cálculo del CVSS: AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N.
  • CVE-2022-47189. Puntuación base CVSS v3.1 de 7,5, siendo el cálculo del CVSS: AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N.
  • CVE-2022-47190. Puntuación base CVSS v3.1 de 10,0, siendo el cálculo del CVSS: AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H.
  • CVE-2022-47191. Puntuación base CVSS v3.1 de 4,3, siendo el cálculo del CVSS: AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N.
  • CVE-2022-47192. Puntuación base CVSS v3.1 de 8,8, siendo el cálculo del CVSS: AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.
Solución
Detalle
  • CVE-2022-47186
    • Un atacante podría subir y/o borrar cualquier tipo de archivo, sin restricción de formato y sin autenticación, en el directorio "upload".
    • El tipo de vulnerabilidad es CWE-434: subida de ficheros potencialmente maliciosos sin restricción.
  • CVE-2022-47187
    • La aplicación web permite la carga de archivos, provocando que un atacante pueda cargar un archivo con contenido HTML,en el cual se puede inyectar una carga útil XSS.
    • El tipo de vulnerabilidad es CWE-79: neutralización inadecuada de la entrada durante la generación de la página web (Cross-Site Scripting).
  • CVE-2022-47188
    • Existe una vulnerabilidad de lectura arbitraria de ficheros. Un atacante, haciendo uso de las credenciales por defecto, podría cargar un archivo de copia de seguridad que contenga un enlace simbólico a /etc/shadow, permitiéndole obtener el contenido de esta ruta.
    • El tipo de vulnerabilidad es CWE-20: validación de entrada inadecuada.
  • CVE-2022-47189
    • Un atacante podría cargar un archivo de firmware que contenga una configuración incorrecta, con el fin de interrumpir la funcionalidad normal del dispositivo.
    • El tipo de vulnerabilidad es CWE-20: validación de entrada inadecuada.
  • CVE-2022-47190
    • Un atacante remoto podría cargar un archivo de firmware que contenga un webshell, permitiéndole ejecutar código arbitrario como root.
    • El tipo de vulnerabilidad es CWE-20: validación de entrada inadecuada.
  • CVE-2022-47191
    • Un atacante remoto podría cargar un archivo de firmware que contenga un archivo con permisos modificados, lo que le permitiría escalar privilegios.
    • El tipo de vulnerabilidad es CWE-20: validación de entrada inadecuada.
  • CVE-2022-47192
    • Un atacante remoto podría subir un archivo de copia de seguridad que contenga un "users.json" modificado al servidor web del dispositivo Generex CS141, permitiéndole reemplazar la contraseña del administrador.
    • El tipo de vulnerabilidad es CWE-20: validación de entrada inadecuada.

Si tienes más información sobre este aviso, ponte en contacto con INCIBE, como se indica en la sección de asignación y publicación de CVE.

Encuesta valoración