CVE

Vulnerabilidad en Apache Tomcat.Tomcat (CVE-2023-46589)

Severidad:
ALTA
Type:
No Disponible / Otro tipo
Fecha de publicación:
28/11/2023
Última modificación:
05/01/2024

Descripción

Vulnerabilidad de validación de entrada incorrecta en Apache Tomcat.Tomcat desde 11.0.0-M1 hasta 11.0.0-M10, desde 10.1.0-M1 hasta 10.1.15, desde 9.0.0-M1 hasta 9.0.82 y desde 8.5.0 hasta 8.5 .95 no analizó correctamente los encabezados de las colas HTTP. Un encabezado de avance que exceda el límite de tamaño del encabezado podría hacer que Tomcat trate una sola solicitud como solicitudes múltiples, lo que generaría la posibilidad de contrabando de solicitudes cuando se encuentre detrás de un proxy inverso. Se recomienda a los usuarios actualizar a la versión 11.0.0-M11 en adelante, 10.1.16 en adelante, 9.0.83 en adelante o 8.5.96 en adelante, que solucionan el problema.

Productos y versiones vulnerables

CPE Desde Hasta
cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:* 8.5.0 (incluyendo) 8.5.96 (excluyendo)
cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:* 9.0.0 (incluyendo) 9.0.83 (excluyendo)
cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:* 10.1.0 (incluyendo) 10.1.16 (excluyendo)
cpe:2.3:a:apache:tomcat:11.0.0:milestone1:*:*:*:*:*:*
cpe:2.3:a:apache:tomcat:11.0.0:milestone10:*:*:*:*:*:*
cpe:2.3:a:apache:tomcat:11.0.0:milestone2:*:*:*:*:*:*
cpe:2.3:a:apache:tomcat:11.0.0:milestone3:*:*:*:*:*:*
cpe:2.3:a:apache:tomcat:11.0.0:milestone4:*:*:*:*:*:*
cpe:2.3:a:apache:tomcat:11.0.0:milestone5:*:*:*:*:*:*
cpe:2.3:a:apache:tomcat:11.0.0:milestone6:*:*:*:*:*:*
cpe:2.3:a:apache:tomcat:11.0.0:milestone7:*:*:*:*:*:*
cpe:2.3:a:apache:tomcat:11.0.0:milestone8:*:*:*:*:*:*
cpe:2.3:a:apache:tomcat:11.0.0:milestone9:*:*:*:*:*:*


botón arriba